Fixing LadioCast crashes & 10.9 SSH issues…

Had some issues when scripting LadioCast broadcasts, started to cause it to crash repeatedly.  The .plist file to delete is com.kawauso.LadioCast.plist from the Library.  Should return the application to defaults.  There was an update to the application in October, so it’s possible this error handling behavior was fixed, but uninstalls did not appear to delete the .plist.

Also, updated to 10.9 “Mavericks” on the server and pretty much all SSH functions stopped working.  Briefly got them working again, but so far it’s been a bust.  Will back update to 10.8 with a fresh re-install.   This machine was an upgrade from 10.6 to 10.8 to 10.9, so it’s possible in all of this OpenSSH failed, but regardless a lot of users have had issues with SSH and 10.9.  An alternative is to run a standalone Linux server or something like a Synology NAS.  Seemingly more reliable those.

SSH debug

http://hints.macworld.com/article.php?story=20080424055927442

The crux is that SSH even when connecting w/ -vvv  or -vT modes won’t tell you precisely why it’s not connecting for obvious security purposes.  This is presuming you’ve double checked all other obvious issues and your public/private key pairs are setup correctly.

In the linked post above Kent Martin writes, the answer is to bind debug to an alternate port on the server side:
/usr/sbin/sshd -d -p 2222

then similarly from the client machine:
ssh -v -p 2222 user@machine_I_am_trying_to_ssh_to

On the server machine terminal you’ll see a more verbose debug log and hopefully it will tell you exactly why your client machine is being rejected.